首页 » Linux » kali linux » kali linux安装ss客户端shadowsocks-qt5

kali linux安装ss客户端shadowsocks-qt5

 
文章目录

当前环境:

VMware Workstation 12 Pro 12.0.0 build-2985596

当前kali linux版本:

Kali-Linux-2016.2-vm-amd64

官方下载地址:

https://images.offensive-security.com/virtual-images/Kali-Linux-2016.2-vm-amd64.7z

当前kali linux是干净的,确保你没有做过更新及源文件更改,确保你当前的环境系统和我这里所演示的相同,如果不同,不保证成功性,本篇文章已经过多次测试。

 

更改当前语言为中文,更改后重启

安装libqtshadowsocks-dev

安装依赖

安装libqtshadowsocks-dev

安装shadowsocks-qt5

安装依赖

安装shadowsocks-qt5

运行ss客户端

启动后可以直接将ss添加到收藏夹,下次直接从收藏夹打开。

安装GenPAC

安装下载GenPAC

接下来点击右上角代理,网络设置,设置自动,我这里的pac文件在root下,所以我把下面地址填进去就可以了,当然你也可以换其他路径
file:///root/autoproxy.pac
genpac详细说明https://github.com/JinnLynn/GenPAC

附:
如果看到下面这种报错,表示缺少依赖,安装所需要的依赖。例:这里就需要安装apt-get install libqrencode-dev libzbar-dev libappindicator-dev
dpkg-checkbuilddeps: error: Unmet build dependencies: libqrencode-dev libzbar-dev libappindicator-dev

原文链接:kali linux安装ss客户端shadowsocks-qt5,转载请注明来源!

8