首页 » Linux » CentOS » gem install redis报错快速解决

gem install redis报错快速解决

 

报错原因:安装redis的话,ruby版本最低是2.2.2,而当前版本是2.0.0,所以无法安装

解决办法:升级ruby版本

注:网上大多数版本都是安装RVM,查看rvm中的版本来安装,速度奇慢无比,我这里直接下载ruby包来安装,速度快的一B。

1、卸载当前ruby(当前使用centos系统)

2、下载ruby稳定版

3、安装ruby


查看安装后的版本

4、设置环境变量

最后添加

保存退出,执行

验证下

5、镜像加速

此时使用gem install redis不会报错了,但是你会发现炒鸡慢,为了更快速的安装,这里使用国内的镜像(https://gems.ruby-china.org/)

6、安装

原文链接:gem install redis报错快速解决,转载请注明来源!

0