首页 » Linux » Jenkins » jenkins更新后出现JNLP-connect,JNLP2-connect警告

jenkins更新后出现JNLP-connect,JNLP2-connect警告

 

在更新jenkins后出现提示

This Jenkins instance uses deprecated protocols: JNLP-connect,JNLP2-connect. It may impact stability of the instance. If newer protocol versions are supported by all system components (agents, CLI and other clients), it is highly recommended to disable the deprecated protocols. Protocol Configuration

这段话大概意思

这个Jenkins实例使用了废弃的协议:JNLP-connect,JNLP2-connect。这可能会影响实例的稳定性。如果所有系统组件(代理、CLI和其他客户端)均支持较新的协议版本,那么强烈建议禁用已弃用的协议。

解决办法:

点击Protocol Configuration→Agents→点击Agent protocols...→取消勾选Protocol/1和Protocol/2→保存即可

原文链接:jenkins更新后出现JNLP-connect,JNLP2-connect警告,转载请注明来源!

4